You must use Microsoft Internet Explorer to use this application.